Etc portage package unmask needs updating

Rated 4.71/5 based on 989 customer reviews

If calculate ~ # emerge -av --autounmask-write =media-sound/audacious-2.5.3 =media-plugins/audacious-plugins-2.5.3 These are the packages that would be merged, in order: Calculating dependencies... [ebuild U ~] dev-libs/libmowgli-0.9.50 [0.7.0] USE="-examples" 103 k B [ebuild U ~] media-sound/audacious-2.5.3 [2.4.4] USE="nls session sse2 (-altivec) -chardet" 1,191 k B [ebuild U ~] media-plugins/audacious-plugins-2.5.3 [2.4.4-r1] USE="aac alsa cdda cue ffmpeg flac gnome ipv6 libnotify lirc mp3 nls scrobbler sdl sse2 vorbis wavpack -adplug (-aqua) -bs2b -fluidsynth (-jack) -lame -libsamplerate -midi -mms -mtp -oss -pulseaudio -sid -sndfile" 3,408 k B Total: 3 packages (3 upgrades), Size of downloads: 4,701 k B The following keyword changes are necessary to proceed: #required by media-plugins/audacious-plugins-2.5.3, required by =media-plugins/audacious-plugins-2.5.3 (argument) =media-plugins/audacious-plugins-2.5.3 ~x86 NOTE: This --autounmask behavior can be disabled by setting EMERGE_DEFAULT_OPTS="--autounmask=n" in Would you like to add these changes to your config files? calculate ~ # etc-update Scanning Configuration files...into the dependency graph, resulting in a slot conflict: dev-lang/perl:0 (dev-lang/perl-5.20.2:0/5.20::gentoo, ebuild scheduled for merge) pulled in by dev-lang/perl (Argument) =dev-lang/perl-5.20* required by (virtual/perl-Digest-1.170.0-r4:0/0::gentoo, installed) ^ ^^^^^ (and 1 more with the same problems) (dev-lang/perl-5.16.3:0/5.16::gentoo, installed) pulled in by dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Pl RPC-0.202.0-r2:0/0::gentoo, installed) ^^^^^^^^ (and 22 more with the same problem)It may be possible to solve this problem by using toprevent one of those packages from being selected.emerge --ask net-dns/bind * IMPORTANT: 3 config files in '/etc/portage' need updating.The Portage system consists of the Portage tree which is a collection of ebuilds, the emerge command which follows the instructions in ebuilds (special scripts), the Portage configuration files and the third-party Portage / emerge tools.

# These settings were set by the catalyst build script that automatically# built this stage.# Please consult /usr/share/portage/config/example for a more# detailed example.

The most common Linux shell is BASH (Bourne Again Shell). Portage is a package management system that is used by Gentoo and Sabayon to install, uninstall and maintain software on your system from the source code.

You need a Sabayon Linux or a Gentoo Linux installation, a working brain (not everybody has one :), some eyes and the ability to read, think and learn. How do I install software in Sabayon from source code?

into the dependency graph, resulting in a slot conflict: dev-libs/openssl:0 (dev-libs/openssl-1.0.1g::gentoo, ebuild scheduled for merge) pulled in by =dev-libs/openssl-1.0.0:0[-bindist] required by (net-dns/bind-9.9.4_p2::gentoo, ebuild scheduled for merge) dev-libs/openssl:0[-bindist] required by (net-dns/bind-9.9.4_p2::gentoo, ebuild scheduled for merge) (dev-libs/openssl-1.0.1g::gentoo, installed) pulled in by =dev-libs/openssl-0.9.6d:0[bindist] required by (net-misc/openssh-5.9_p1-r4::gentoo, installed) It may be possible to solve this problem by using to prevent one of those packages from being selected.

However, it is also possible that conflicting dependencies exist such that they are impossible to satisfy simultaneously.

Leave a Reply